شما هنوز به سیستم وارد نشده اید.

#1 2016-06-03 14:20:20

LinArcX
عضو
ثبت شده: 2015-09-18
ارسال ها: 735
وب سایت

نصب نشدن لایبری unicurses با pip

عرض احترام
دوستان میخوام کتابخونه unicurse رو با ابزار pip بگیرم منتهی این ارور رو بهم میده:

  Could not find a version that satisfies the requirement unicurses (from versions: )
No matching distribution found for unicurses

اینم دستور من واسه گرفتن این کتابخونه:

[saeed@saeed ~]$ pip search unicurses
UniCurses (1.2)  - A unified OS-independent Curses wrapper for Python
[saeed@saeed ~]$ sudo pip install unicurses
Collecting unicurses
  Could not find a version that satisfies the requirement unicurses (from versions: )
No matching distribution found for unicurses
[saeed@saeed ~]$ 

any idea?

آخرین ویرایش توسط LinArcX (2016-06-03 14:20:50)


"Enough!!!Don't Use "DEFAULTS" Any More..."make it simple stupid

آفلاین

#2 2016-06-03 16:53:49

Риал Краесис
عضو
از : تهران
ثبت شده: 2015-09-16
ارسال ها: 309

پاسخ: نصب نشدن لایبری unicurses با pip

فک کنم باید ورژن پایپ هم مشخص کنی تو دستور!
پایپ ۲ یا پایپ ۳!


*** I FIGHT FOR USERS ***

آفلاین

#3 2016-06-03 17:57:32

LinArcX
عضو
ثبت شده: 2015-09-18
ارسال ها: 735
وب سایت

پاسخ: نصب نشدن لایبری unicurses با pip

ظاهرا این کتابخونه دیگه توسعه داده نمیشه.واسه همین نمیشه نصبش کرد و این ارور خاص رو میده.کاری که تونستم بکنم این بود که سورس رو مستقیم از گیت هابش گرفتم و با دستورات زیر اقدام به نصبش کردم:

git clone git@github.com:Chiel92/unicurses.git
cd unicurses
sudo python setup.py install

هر چند نصب نشد بازم sad
در نتیجه تصمیم گرفتم برم از کتابخونه استاندارد curses استفاده کنم.به همین سادگی smile


"Enough!!!Don't Use "DEFAULTS" Any More..."make it simple stupid

آفلاین

پانوشت انجمن

پشتیبانی توسط تیم آرچ لینوکس ایران و نیرو گرفته با FluxBB