شما هنوز به سیستم وارد نشده اید.

#1 2017-01-30 12:51:05

LinArcX
عضو
ثبت شده: 2015-09-18
ارسال ها: 735
وب سایت

غیر فعال کردن موقع بوت سرویس mysql

همیشه از طریق systemd میشه سرویس ها رو با دستور زیر متوقف کرد:

sudo systemctl disable foo.service 

ولی سرویس mysql نشون میده که از این قضیه مستثنی ست.کسی این مشکل رو داشته قبلا؟

آخرین ویرایش توسط LinArcX (2017-01-30 14:50:08)


"Enough!!!Don't Use "DEFAULTS" Any More..."make it simple stupid

آفلاین

#2 2017-01-30 14:39:52

AmiNimA
عضو
ثبت شده: 2015-11-27
ارسال ها: 224
وب سایت

پاسخ: غیر فعال کردن موقع بوت سرویس mysql

فکر کنم disable و enable برای فعال/غیرفعال کردن سرویس هنگام بوت باشه. برای توقف سرویس باید از stop استفاده کرد.


لینوکس یک فرهنگ است. یک فرهنگ خوب

آفلاین

#3 2017-01-30 14:51:05

LinArcX
عضو
ثبت شده: 2015-09-18
ارسال ها: 735
وب سایت

پاسخ: غیر فعال کردن موقع بوت سرویس mysql

بله حرفتون درسته.تایتل رو تصحیح کردم.منظورم این بود موقع ریستارت با اینکه سرویس رو دیزیبل کردم، ولی هم چنان سرویس بالا هست!


"Enough!!!Don't Use "DEFAULTS" Any More..."make it simple stupid

آفلاین

#4 2017-01-30 17:44:57

Arcush
Moderator
ثبت شده: 2015-09-15
ارسال ها: 1,292

پاسخ: غیر فعال کردن موقع بوت سرویس mysql

فقط برای اینکه کاملا مطمئن بشیم، mysql رو بجای mysqld به کار نمیبرید؟

آفلاین

#5 2017-01-31 00:04:53

LinArcX
عضو
ثبت شده: 2015-09-18
ارسال ها: 735
وب سایت

پاسخ: غیر فعال کردن موقع بوت سرویس mysql

درود بر عیسی عزیز.
اسم سرویس mariadb.service هست.اصلا چیزی به نام mysql یا mysqldوجود نداره.


"Enough!!!Don't Use "DEFAULTS" Any More..."make it simple stupid

آفلاین

#6 2017-02-01 09:30:23

ehsan_faal
عضو
از : تهران
ثبت شده: 2015-10-02
ارسال ها: 270

پاسخ: غیر فعال کردن موقع بوت سرویس mysql

سلام.
شاید بی ربط باشه ولی فقط disable کردن یه سرویس واسه غیرفعال کردنش کفایت نمیکنه، اگه socket هم داره اونم بایستی غیرفعال بشه


Mahatma Gandhi - The weak can never forgive. Forgiveness is the attribute of the strong

آفلاین

#7 2017-02-01 13:41:07

LinArcX
عضو
ثبت شده: 2015-09-18
ارسال ها: 735
وب سایت

پاسخ: غیر فعال کردن موقع بوت سرویس mysql

ممنونم ازت احسان عزیز.جواب شما منو کنجکاو کرد که برم ببینم در مسیر/usr/lib/systemd/system چه خبره.تنها چهار یونیت زیر موجود بودن و خبری از یونیت سوکت مای.اس.کیو.ال نبود:

   
mariadb@.service      
mariadb.service                 
mysqld@.service 
mysqld.service 

دستورات زیر رو زدم باز هم افاقه نکرد:

sudo systemctl disable mysqld 
sudo systemctl disable mariadb.service 
systemctl daemon-reload 

انگار یه چیزی داره هر سری استارت ش میکنه دوباره.


"Enough!!!Don't Use "DEFAULTS" Any More..."make it simple stupid

آفلاین

#8 2017-02-01 15:51:58

Arcush
Moderator
ثبت شده: 2015-09-15
ارسال ها: 1,292

پاسخ: غیر فعال کردن موقع بوت سرویس mysql

سعیدجان، آیا مسیری رو از حالت استاندارد خودش، به جای دیگری تغییر دادید؟ لطفا یه status از سرویس مذکور هم بدید.

آفلاین

#9 2017-02-01 20:55:11

LinArcX
عضو
ثبت شده: 2015-09-18
ارسال ها: 735
وب سایت

پاسخ: غیر فعال کردن موقع بوت سرویس mysql

عیسی جان والا دقیق یادم نمیاد چکار کردوم اون زمان موقع نصب کردنش.
این استاتوس mariadb:

 ❯ sudo systemctl status mariadb.service                                                                                                                                              [19:53:36]
● mariadb.service - MariaDB database server
   Loaded: loaded (/usr/lib/systemd/system/mariadb.service; disabled; vendor preset: disabled)
   Active: active (running) since Wed 2017-02-01 19:51:58 IRST; 1min 38s ago
  Process: 882 ExecStartPost=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
  Process: 644 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ]   && systemctl set-environment _WSREP_START_POSITION=$VAR || e
  Process: 626 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
 Main PID: 703 (mysqld)
   Status: "Taking your SQL requests now..."
    Tasks: 27 (limit: 4915)
   CGroup: /system.slice/mariadb.service
           └─703 /usr/sbin/mysqld

Feb 01 19:51:53 saeed mysqld[703]: 2017-02-01 19:51:53 139760543931904 [Note] InnoDB: Highest supported file format is Barracuda.
Feb 01 19:51:55 saeed mysqld[703]: 2017-02-01 19:51:55 139760543931904 [Note] InnoDB: 128 rollback segment(s) are active.
Feb 01 19:51:55 saeed mysqld[703]: 2017-02-01 19:51:55 139760543931904 [Note] InnoDB: Waiting for purge to start
Feb 01 19:51:55 saeed mysqld[703]: 2017-02-01 19:51:55 139760543931904 [Note] InnoDB:  Percona XtraDB (http://www.percona.com) 5.6.34-79.1 started; log sequence number 9465145
Feb 01 19:51:56 saeed mysqld[703]: 2017-02-01 19:51:56 139760014194432 [Note] InnoDB: Dumping buffer pool(s) not yet started
Feb 01 19:51:56 saeed mysqld[703]: 2017-02-01 19:51:56 139760543931904 [Note] Plugin 'FEEDBACK' is disabled.
Feb 01 19:51:57 saeed mysqld[703]: 2017-02-01 19:51:57 139760543931904 [Note] Server socket created on IP: '::'.
Feb 01 19:51:57 saeed mysqld[703]: 2017-02-01 19:51:57 139760543931904 [Note] /usr/sbin/mysqld: ready for connections.
Feb 01 19:51:57 saeed mysqld[703]: Version: '10.1.21-MariaDB'  socket: '/run/mysqld/mysqld.sock'  port: 3306  MariaDB Server
Feb 01 19:51:58 saeed systemd[1]: Started MariaDB database server.

اینم استاتوس mysqld:

 ❯ sudo systemctl status mysqld.service                                                                                                                                               [19:55:27]
● mariadb.service - MariaDB database server
   Loaded: loaded (/usr/lib/systemd/system/mariadb.service; disabled; vendor preset: disabled)
   Active: active (running) since Wed 2017-02-01 19:51:58 IRST; 3min 29s ago
  Process: 882 ExecStartPost=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
  Process: 644 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ]   && systemctl set-environment _WSREP_START_POSITION=$VAR || e
  Process: 626 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
 Main PID: 703 (mysqld)
   Status: "Taking your SQL requests now..."
    Tasks: 27 (limit: 4915)
   CGroup: /system.slice/mariadb.service
           └─703 /usr/sbin/mysqld

Feb 01 19:51:53 saeed mysqld[703]: 2017-02-01 19:51:53 139760543931904 [Note] InnoDB: Highest supported file format is Barracuda.
Feb 01 19:51:55 saeed mysqld[703]: 2017-02-01 19:51:55 139760543931904 [Note] InnoDB: 128 rollback segment(s) are active.
Feb 01 19:51:55 saeed mysqld[703]: 2017-02-01 19:51:55 139760543931904 [Note] InnoDB: Waiting for purge to start
Feb 01 19:51:55 saeed mysqld[703]: 2017-02-01 19:51:55 139760543931904 [Note] InnoDB:  Percona XtraDB (http://www.percona.com) 5.6.34-79.1 started; log sequence number 9465145
Feb 01 19:51:56 saeed mysqld[703]: 2017-02-01 19:51:56 139760014194432 [Note] InnoDB: Dumping buffer pool(s) not yet started
Feb 01 19:51:56 saeed mysqld[703]: 2017-02-01 19:51:56 139760543931904 [Note] Plugin 'FEEDBACK' is disabled.
Feb 01 19:51:57 saeed mysqld[703]: 2017-02-01 19:51:57 139760543931904 [Note] Server socket created on IP: '::'.
Feb 01 19:51:57 saeed mysqld[703]: 2017-02-01 19:51:57 139760543931904 [Note] /usr/sbin/mysqld: ready for connections.
Feb 01 19:51:57 saeed mysqld[703]: Version: '10.1.21-MariaDB'  socket: '/run/mysqld/mysqld.sock'  port: 3306  MariaDB Server
Feb 01 19:51:58 saeed systemd[1]: Started MariaDB database server.

آخرین ویرایش توسط LinArcX (2017-02-01 20:56:33)


"Enough!!!Don't Use "DEFAULTS" Any More..."make it simple stupid

آفلاین

پانوشت انجمن

پشتیبانی توسط تیم آرچ لینوکس ایران و نیرو گرفته با FluxBB