شما هنوز به سیستم وارد نشده اید.

#26 2016-01-01 14:19:27

Arcush
Moderator
ثبت شده: 2015-09-15
ارسال ها: 1,308

پاسخ: درخواست بسته genymotion[بالاخره حل شد! :D]

راه سوم که خیلی آسونتره: روی سیستم های ۳۲ که همون سورسی که توی پیج AUR هست، کافیه. اما برای سیستم های با معماری ۶۴، این تاربال رو استفاده کنید:
http://files2.genymotion.com/genymotion … ux_x64.bin
با تشکر از مجتبی عزیز.

i5vn_screenshot_at_2016-01-01_13:12:32.png

آفلاین

#27 2016-01-01 16:37:15

LinArcX
عضو
ثبت شده: 2015-09-18
ارسال ها: 735
وب سایت

پاسخ: درخواست بسته genymotion[بالاخره حل شد! :D]

مرسی عیسی جان،مرسی مجتبی عزیز..مرسی جامعه کاربری دوست داشتنی آرچ که خیرخواهانه و از روی مسیولیت(و البته بدون چشم داشت)به دوستانتون کمک میکنید. smile
بعد از تلاش هایی که عیسی عزیز فرمودن و البته حدس هایی که میزدیم من این بحث رو درانجمن اصلی آرچ انگلیسی مطرح کردم و با این جواب از کاربری به نام lone_wolf مواجه شدم:

Hmm, genymotion is a QT program, but your errors sofar are all GTK related (libpng warnings tend to be harmless) .

What WM/DE are you using ?

جرقه اول در ذهن عیسی زده شد. big_smile
(اینم بگم که من داشتم تو تلگرام با عیسی چت میکردم و اینا رو بهش میگفتم.)
عیسی عزیز گفت مشکل از کیوت هستش. kde نصب کن..منم برگشتم بهش گفتم که مجتبی روی گنوم، جنی رو نصب کرده..این شد که پای مجتبی هم به بازی کشیده شد..گفتم مجتبی چکار کنم گفت تو صفحه aur ش عدد 86 رو به 64 تبدیل کن تا سورس نسخه 64 بیتی برات دانلود بشه..همزمان عیسی بهمون گفت خروجی این دستور رو بذاریم:

ls /opt/genymotion

نتایج جالب بود..هیچ کدوم از خروجی هامون شبیه هم نبود..خخخ
علتش هم این بود که مجتبی نسخه 64 بیتی و عیسی نسخه 32 بیتی جنی رو دانلود کرده بود(ورژن این دوستان 2.6.0 بود و مال من 2.5.2)
این هم خروجی هامون:
مجتبی:

device-upgrade              
libprotobuf.so.7
genymotion                  
libavutil.so.51        
libssl.so.1.0.0
genymotion-shell            
libcrypto.so.1.0.0     
libswscale.so.2
genyshell                   
libicudata.so.53       
platforms
gmtool                      
libicui18n.so.53       
player
icons                       
libicuuc.so.53         
plugins
imageformats                
libminicrypt.so        
sqldrivers
libminicrypt.so.1      
tools
libminicrypt.so.1.0    
translations
libminicrypt.so.1.0.0
----------------------------------
lib64GLES_V2_translator.so  
lib64OpenglRender.so   
lib64EGL_translator.so     
lib64GLES_CM_translator.so  

عیسی:

device-upgrade       
libprotobuf.so.7
genymotion       
libavutil.so.51         
libssl.so.1.0.0
genymotion-shell      
libcrypto.so.1.0.0    
libswscale.so.2
genyshell        
libicudata.so.53         
platforms
gmtool    
libicui18n.so.53          
player
icons   
libicuuc.so.53            
plugins
 imageformats        
libminicrypt.so           
sqldrivers
libminicrypt.so.1         
tools
libminicrypt.so.1.0       
translations
libminicrypt.so.1.0.0    
---------------------------
libOpenglRender.so        
 libGLES_CM_translator.so 
 libGLES_V2_translator.so 
 libQt5WebKitWidgets.so.5
libEGL_translator.so  

من:

device-upgrade    
imageformats              
libavutil.so.51           
libssl.so
genymotion        
libcrypto.so              
libswscale.so.2
genymotion-shell
player
plugins
genyshell         
sqldrivers
gmtool            
tools
icons             
libprotobuf.so.7          
translations
-----------------
libqca.so.2
crypto    
 libEGL_translator.so     
genymotion-tool   
libGLES_CM_translator.so  
libGLES_V2_translator.so  
libOpenglRender.so        

و این هم اختلاف بین خروجی هامون:

***Mojtaba****
lib64GLES_CM_translator.so  
lib64OpenglRender.so   
lib64GLES_CM_translator.so  
lib64GLES_V2_translator.so  
--------------------------
***Arcush****
libOpenglRender.so        
 libGLES_CM_translator.so 
 libGLES_V2_translator.so 
 libQt5WebKitWidgets.so.5
libEGL_translator.so  
--------------------------
****Saeed****
libqca.so.2
crypto    
 libEGL_translator.so     
genymotion-tool   
libGLES_CM_translator.so  
libGLES_V2_translator.so  
libOpenglRender.so        

بنا به پیشنهاد عیسی عزیز نسخه 2.5.2 رو حذف کردم و نسخه 2.6.0 رو دانلود کردم البته نسخه 64 بیتی شو..فایل pkgbuild رو دوباره با مقادیر جدید جنریت کردم و عملیات نصب به درستی انجام شد.
باورم نمیشد بعد تقریبا دو ماه بتونم رخ زیبای جنی رو ببینم: big_smile
o0qr_screenshot_from_2016-01-01_14-46-00.png
بله نصب شد.و تلاش هامون به ثمر نشست..بازم جا داره از تلاش های بی وقفه ت تشکر کنم عیسی..خیلی گلی..
اینم جمله ای که عیسی در وصف مجتبی گفت:

به مجتبی بگو:  آفرین به مجتبی، مجتبیای که شرودینگر گفت: مجتبی بزرگ.

big_smile big_smile big_smile
الان دیگه با خیال راحت میتونم ختم جلسه این تاپیکو اعلام کنم و برم انگری برد 2 مو بازی کنم smile big_smile .البته با کوله باری از تجربه های خوب و دوست داشتنی ..

آخرین ویرایش توسط LinArcX (2016-01-01 16:55:33)


"Enough!!!Don't Use "DEFAULTS" Any More..."make it simple stupid

آفلاین

#28 2016-01-01 18:55:39

LinArcX
عضو
ثبت شده: 2015-09-18
ارسال ها: 735
وب سایت

پاسخ: درخواست بسته genymotion[بالاخره حل شد! :D]

یه آموزش کوچولو هم بدم از راه اندازی جنی موشن:
برای استفاده از جنی موشن ابتدا باید برید تو سایتش ثبت نام کنید.بعد با استفاده از یوزر پسی که از اونجا دریافت کردید تو نرم افزار لاگین میکنید.بعدش باید ویرچوال دیوایس ها رو اضافه کنید.دو تا راه عمده دارین واسه دانلود ویرچوال دیوایس ها:
۱-از داخل خود جنی اجازه بدین فایل های شبیه ساز(که پسوند ova. دارند) دانلود بشند.
۲-سر جنی رو شیره بمالین و خودتون برین جداگونه شبییه سازها رو دانلود کنید با دانلود منیجرتون!
اگه خواستین روش دوم رو برین، یه سایتی هست که فایل های ova. رو با لینک مستقیم در اختیارتون قرار میده.فقط کافیه اونها رو دانلود کنید و در مسیر زیر بریزیدش:

/~/.Genymobile/Genymotion/ova

۳-از لاگ فایلی که تو مسیر /~/.Genymobile استفاده کنید.(به نام:genymotion.log).در واقع در این لاگ فایل میتونید کل کارهایی که با جنی کردین رو گزارش وار ببینید.میتونید یه شبیه ساز رو دانلود کنید و بعد از شروع بلافاصله متوقفش کنید.برید این لاگ فایل رو باز کنید.آدرس کامل فایل ova. رو تو خطوط آخرش خواهید دید.حالشو ببرین D:
اینم چند تا لینک خوب:
۱-نصب و راه اندازی اولیه جنی
۲- آموزش دوم
3-آموزش سوم

آخرین ویرایش توسط LinArcX (2016-10-19 17:44:22)


"Enough!!!Don't Use "DEFAULTS" Any More..."make it simple stupid

آفلاین

پانوشت انجمن

پشتیبانی توسط تیم آرچ لینوکس ایران و نیرو گرفته با FluxBB