شما هنوز به سیستم وارد نشده اید.

#1 2016-06-28 06:24:11

sadrabp
عضو
از : تهران
ثبت شده: 2016-06-26
ارسال ها: 6

ارور دیپندنسی پرل 5.14.0

سلام دوستان. چند وقتیه که نمیتونم از AUR خیلی از بستهها رو نصب کنم. ارور میده که:

error: failed to prepare transaction (could not satisfy dependencies)
:: perl-curses: installing perl (5.24.0-1) breaks dependency 'perl<5.23'

من رفتم pacman -Qi رو دیدم:

Name            : perl-curses
Groups          : None
Provides        : None
Depends On      : perl  ncurses  perl>=5.22  perl<5.23
Optional Deps   : None
Required By     : vit
Optional For    : None
Conflicts With  : None
Replaces        : None

الان تکلیف چیه؟ بسی سرچ کردم ولی نفهمیدم غیر از پاک کردن این چه راهی وجود داره.
ممنون.

ویرایش: اون ویت یه کلاینت برای TaskWarrior هستش... مشکل خاصی با پاک کردنش ندارم ولی میخوام بدونم اگه بعداً با پکیج دیگهای همین قضیه پیش اومد راهی غیر از پاک کردن هست یا نه.

آخرین ویرایش توسط sadrabp (2016-06-28 06:44:30)

آفلاین

#2 2016-06-28 09:28:11

morealaz
عضو
از : کرمان
ثبت شده: 2016-03-19
ارسال ها: 292

پاسخ: ارور دیپندنسی پرل 5.14.0

چون خیلی از بسته ها با perl کار میکنند معمولا بعد از هر ورژن جدید perl این مشکل پیش میاد که بعضی برنامه ها چون با ورژن جدید بروز نشدند ناسازگاری پیدا کنند. perl 5.24 هم چون به تازگی وارد مخازن آرچ شده تا همه بسته ها به خصوص بسته های AUR خودشون رو بروز کنند طول میکشه. بسته perl-curses رو من چک کردم با perl 5.24 سازگار شده و دیپندیسی هاش رو بروز کردند. اگر سیستمتون رو آپدیت کنید درست میشه.

آفلاین

پانوشت انجمن

پشتیبانی توسط تیم آرچ لینوکس ایران و نیرو گرفته با FluxBB