شما هنوز به سیستم وارد نشده اید.

#1 2016-07-05 01:05:12

enghamid
عضو
از : Tehran
ثبت شده: 2016-06-17
ارسال ها: 231
وب سایت

failed to prepare transaction (conflicting dependencies)

لطفا کمکم کنید

loading packages...
resolving dependencies...
warning: cannot resolve "xorg-server<1.18.0", a dependency of "catalyst-utils"
warning: cannot resolve "catalyst-utils", a dependency of "catalyst-libgl"
warning: cannot resolve "xorg-server<1.18.0", a dependency of "catalyst-utils"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      catalyst-libgl  catalyst-utils

:: Do you want to skip the above packages for this upgrade? [y/N] y
looking for conflicting packages...
:: opencl-catalyst and ocl-icd are in conflict (libcl). Remove ocl-icd? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: opencl-catalyst and ocl-icd are in conflict
==> WARNING: Your packages are saved in /tmp/yaourt-tmp-hamid
==> Restart building catalyst ? [y/N]
==> ---------------------------------
==> 

این مشکل زمان نصب درایور amd پیش اومده


وسعت دنیای هر کس به اندازه تفکر اوست
آدم های  بزرگ  دنیای  بزرگی  دارند
کسی را با کوتاه  فکری از خود نمی رنجانند
http://enghamid.ir

آفلاین

#2 2016-07-05 01:40:57

Arcush
Moderator
ثبت شده: 2015-09-15
ارسال ها: 1,281

پاسخ: failed to prepare transaction (conflicting dependencies)

این مشکل رو شما بوجود آوردید. big_smile اولین مورد اینکه

Do you want to skip the above packages for this upgrade? [y/N] y

نشون میده اولا سیستمتون به روز نیست و ثانیا شما نخواستید چندتا از بسته ها آپگرید بشن. هردوی اینها زمینه ساز مشکلات آتی خواهند بود. بنابراین قبل از نصب بسته ها، سیستمتون رو با sudo pacman -Suy به روز کنید.

دومین مورد هم اینکه دوتا بسته باهم کانفلیکت دارن و مدیر بسته برای نصب یکیش از شما میخواد تا اجازه بدید دیگری رو حذف کنه. ولی شما اجازه ندادید.

:: opencl-catalyst and ocl-icd are in conflict (libcl). Remove ocl-icd? [y/N] n

معلومه این منطقی نیست که دوتا بسته که باهم کانفلیکت دارن همزمان کار کنن (گرچه میتونید مدیر بسته رو مجبور به اینکار کنید ولی این موضوع بحث ما نیست). بنابراین *طبیعیه* که این خطاها بوجود بیان.

آفلاین

#3 2016-07-05 02:12:19

Риал Краесис
عضو
از : تهران
ثبت شده: 2015-09-16
ارسال ها: 303

پاسخ: failed to prepare transaction (conflicting dependencies)

Arcush نوشته است که:

این مشکل رو شما بوجود آوردید. big_smile اولین مورد اینکه

Do you want to skip the above packages for this upgrade? [y/N] y

نشون میده اولا سیستمتون به روز نیست و ثانیا شما نخواستید چندتا از بسته ها آپگرید بشن. هردوی اینها زمینه ساز مشکلات آتی خواهند بود. بنابراین قبل از نصب بسته ها، سیستمتون رو با sudo pacman -Suy به روز کنید.

دومین مورد هم اینکه دوتا بسته باهم کانفلیکت دارن و مدیر بسته برای نصب یکیش از شما میخواد تا اجازه بدید دیگری رو حذف کنه.

:: opencl-catalyst and ocl-icd are in conflict (libcl). Remove ocl-icd? [y/N] n

معلومه این منطقی نیست ( گرچه میتونید مدیر بسته رو مجبور به اینکار کنید). بنابراین *طبیعیه* که این خطاها بوجود بیان.


ارکوش جان مشکل چیز دیگه ایه!
ایراد از به روز بودن سیستم این دوستمونه!
چون amd  به xorg-server با نسخه پایین تر از ۱٫۱۸ نیاز داره گیر داده!
من هم این مشکل رو داشتم برای رفعش xorg-server رو داوونگرید کردم که کلی مشکل دیگه ایجاد کرد!
بلاجبار بیخیالش شدم! smile


*** I FIGHT FOR USERS ***

آفلاین

#4 2016-07-05 02:20:17

Arcush
Moderator
ثبت شده: 2015-09-15
ارسال ها: 1,281

پاسخ: failed to prepare transaction (conflicting dependencies)

Риал Краесис نوشته است که:
Arcush نوشته است که:

این مشکل رو شما بوجود آوردید. big_smile اولین مورد اینکه

Do you want to skip the above packages for this upgrade? [y/N] y

نشون میده اولا سیستمتون به روز نیست و ثانیا شما نخواستید چندتا از بسته ها آپگرید بشن. هردوی اینها زمینه ساز مشکلات آتی خواهند بود. بنابراین قبل از نصب بسته ها، سیستمتون رو با sudo pacman -Suy به روز کنید.

دومین مورد هم اینکه دوتا بسته باهم کانفلیکت دارن و مدیر بسته برای نصب یکیش از شما میخواد تا اجازه بدید دیگری رو حذف کنه.

:: opencl-catalyst and ocl-icd are in conflict (libcl). Remove ocl-icd? [y/N] n

معلومه این منطقی نیست ( گرچه میتونید مدیر بسته رو مجبور به اینکار کنید). بنابراین *طبیعیه* که این خطاها بوجود بیان.


ارکوش جان مشکل چیز دیگه ایه!
ایراد از به روز بودن سیستم این دوستمونه!
چون amd  به xorg-server با نسخه پایین تر از ۱٫۱۸ نیاز داره گیر داده!
من هم این مشکل رو داشتم برای رفعش xorg-server رو داوونگرید کردم که کلی مشکل دیگه ایجاد کرد!
بلاجبار بیخیالش شدم! smile

مجتبی جان منم اولین موضوعی که اشاره کردم، همین بروز نبودن سیستم بود. این خیلی روشنه. اما خطای اصلی که بخاطر اون ادامه نصب انجام نشده، کانفلیکت پکیج ها هست. اینم خیلی روشنه.

آفلاین

#5 2016-07-05 02:47:18

Риал Краесис
عضو
از : تهران
ثبت شده: 2015-09-16
ارسال ها: 303

پاسخ: failed to prepare transaction (conflicting dependencies)

Arcush نوشته است که:
Риал Краесис نوشته است که:
Arcush نوشته است که:

این مشکل رو شما بوجود آوردید. big_smile اولین مورد اینکه

Do you want to skip the above packages for this upgrade? [y/N] y

نشون میده اولا سیستمتون به روز نیست و ثانیا شما نخواستید چندتا از بسته ها آپگرید بشن. هردوی اینها زمینه ساز مشکلات آتی خواهند بود. بنابراین قبل از نصب بسته ها، سیستمتون رو با sudo pacman -Suy به روز کنید.

دومین مورد هم اینکه دوتا بسته باهم کانفلیکت دارن و مدیر بسته برای نصب یکیش از شما میخواد تا اجازه بدید دیگری رو حذف کنه.

:: opencl-catalyst and ocl-icd are in conflict (libcl). Remove ocl-icd? [y/N] n

معلومه این منطقی نیست ( گرچه میتونید مدیر بسته رو مجبور به اینکار کنید). بنابراین *طبیعیه* که این خطاها بوجود بیان.


ارکوش جان مشکل چیز دیگه ایه!
ایراد از به روز بودن سیستم این دوستمونه!
چون amd  به xorg-server با نسخه پایین تر از ۱٫۱۸ نیاز داره گیر داده!
من هم این مشکل رو داشتم برای رفعش xorg-server رو داوونگرید کردم که کلی مشکل دیگه ایجاد کرد!
بلاجبار بیخیالش شدم! smile

مجتبی جان منم اولین موضوعی که اشاره کردم، همین بروز نبودن سیستم بود. این خیلی روشنه. اما خطای اصلی که بخاطر اون ادامه نصب انجام نشده، کانفلیکت پکیج ها هست. اینم خیلی روشنه.

برعکس ایراد از زیادی بهروز بودن سیستم دوستمونه


*** I FIGHT FOR USERS ***

آفلاین

#6 2016-07-05 03:00:41

Arcush
Moderator
ثبت شده: 2015-09-15
ارسال ها: 1,281

پاسخ: failed to prepare transaction (conflicting dependencies)

ممنون. الان متوجه شدم. پس باید منتظر باشه تا دیپندنسی ها با ورژن جدید سازگار بشن.

آفلاین

پانوشت انجمن

پشتیبانی توسط تیم آرچ لینوکس ایران و نیرو گرفته با FluxBB