شما هنوز به سیستم وارد نشده اید.

#1 2017-02-17 17:42:42

LinArcX
عضو
ثبت شده: 2015-09-18
ارسال ها: 747

خطا هنگام اجرای foxit reader

موقع اجرا کردن این برنامه با خطای زیر مواجه میشم:

 ❯ foxitreader                                                       [16:40:29]
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
[2]    17618 abort (core dumped)  foxitreader

علت چی میتونه باشه؟


"Enough!!!Don't Use "DEFAULTS" Any More..."make it simple stupid

آفلاین

#2 2017-02-17 19:53:22

morealaz
عضو
از : کرمان
ثبت شده: 2016-03-19
ارسال ها: 298

پاسخ: خطا هنگام اجرای foxit reader

سعیدجان فایل libqxcb.so برای پلاگین xcb لازمه که این فایل جزيی از بسته qt5-base هست. اگر این بسته رو نصب کردی و بازهم مشکل داری در اجرای برنامه، احتمالا foxitreader به یه ورژن قدیمی تر نیاز داره. با برنامه ldd میتونی چک کنی که foxitreader برای اجرا به چه library هایی نیاز داره.

$ ldd /usr/bin/foxitreader

به عنوان پارامتر آدرس فایل اجرایی برنامه رو قرار بده.

آفلاین

#3 2017-02-18 11:11:25

LinArcX
عضو
ثبت شده: 2015-09-18
ارسال ها: 747

پاسخ: خطا هنگام اجرای foxit reader

ممنونم از پاسخت محمد عزیز.بله بسته qt-base نصب هست رو سیستمم.و خروجی دستوری که گفتین:

 ❯ ldd /usr/bin/foxitreader                                                                                 [10:04:37]
	not a dynamic executable

(تو پرانتز اینم بگم که البته من یه سرکی هم کشیدم تو صفحه مخصوص این پکیج تو AURو انگاری out of date شده!)چیزی که به ذهنم رسید این بود که از دستور file استفاده کنم:

 ❯ file /usr/bin/foxitreader                                                                                [10:06:44]
/usr/bin/foxitreader: symbolic link to /usr/lib/foxitreader/FoxitReader.sh

چیزی که من متوجه شدم این هستش که نویسنده محترم این pkgbuild اومده همه so. فایل ها رو تو مسیر  /usr/lib/foxitreader/lib  قرار داده.حالا نمیدونم مشکل از عدم رعایت دیپندنسی هایش بوده یا pkgbuild بد نوشته شده یا..
بگذریم.تصمیم گرفتم بسته رو از خود سایت رسمی برنامه بگیرم و طبق دستورات خودش برنامه رو نصب کنم.

آخرین ویرایش توسط LinArcX (2017-02-18 11:12:56)


"Enough!!!Don't Use "DEFAULTS" Any More..."make it simple stupid

آفلاین

پانوشت انجمن

پشتیبانی توسط تیم آرچ لینوکس ایران و نیرو گرفته با FluxBB