شما هنوز به سیستم وارد نشده اید.

#1 2017-04-14 13:04:30

Programmer
عضو
از : root/
ثبت شده: 2015-10-01
ارسال ها: 397

مشکل در نصب و بروز رسانی بسته ها [حل شد]

درود به همه دوستان عزیز
می خوام steam رو نصب کنم اما مشکل زیر پیش میادش ! (از مانجارو دارم استفاده می کنم)

rror: failed to commit transaction (conflicting files)
libglvnd: /usr/lib/libEGL.so exists in filesystem
libglvnd: /usr/lib/libEGL.so.1 exists in filesystem
libglvnd: /usr/lib/libEGL.so.1.0.0 exists in filesystem
libglvnd: /usr/lib/libGL.so exists in filesystem
libglvnd: /usr/lib/libGL.so.1 exists in filesystem
libglvnd: /usr/lib/libGLESv1_CM.so exists in filesystem
libglvnd: /usr/lib/libGLESv1_CM.so.1 exists in filesystem
libglvnd: /usr/lib/libGLESv2.so exists in filesystem
libglvnd: /usr/lib/libGLESv2.so.2 exists in filesystem
libglvnd: /usr/lib/libGLESv2.so.2.0.0 exists in filesystem
Errors occurred, no packages were upgraded.

ممنون میشم راهنمایی کنید

آخرین ویرایش توسط Programmer (2017-04-14 13:34:47)


Impossible Impossible
Imagination is more important than science
به بلاگ من سر بزنید smile
به اینستاگرام من سر بزنید smile

آفلاین

#2 2017-04-14 13:33:53

Programmer
عضو
از : root/
ثبت شده: 2015-10-01
ارسال ها: 397

پاسخ: مشکل در نصب و بروز رسانی بسته ها [حل شد]

Programmer نوشته است که:

درود به همه دوستان عزیز
می خوام steam رو نصب کنم اما مشکل زیر پیش میادش ! (از مانجارو دارم استفاده می کنم)

rror: failed to commit transaction (conflicting files)
libglvnd: /usr/lib/libEGL.so exists in filesystem
libglvnd: /usr/lib/libEGL.so.1 exists in filesystem
libglvnd: /usr/lib/libEGL.so.1.0.0 exists in filesystem
libglvnd: /usr/lib/libGL.so exists in filesystem
libglvnd: /usr/lib/libGL.so.1 exists in filesystem
libglvnd: /usr/lib/libGLESv1_CM.so exists in filesystem
libglvnd: /usr/lib/libGLESv1_CM.so.1 exists in filesystem
libglvnd: /usr/lib/libGLESv2.so exists in filesystem
libglvnd: /usr/lib/libGLESv2.so.2 exists in filesystem
libglvnd: /usr/lib/libGLESv2.so.2.0.0 exists in filesystem
Errors occurred, no packages were upgraded.

ممنون میشم راهنمایی کنید

خب مشکل برطرف شد . اون فایل هایی که در بالا گفتم conflict شدن رو منتقل کردم به یک فایل دیگه داخل همون مسیر و دوباره زدم تا استیم رو نصب کنه و الان هم مشکل بروز رسانی حل شد و هم مشکل اجرای استیم
نمونه کد انتقال رو قرار میدم برای دوستان تازه وارد :

sudo mv /usr/lib/libGLESv2.so  /usr/lib/libEGL.so_bkp

آدرس تاپیکی رو هم که برای حل مشکل کمکم کرد براتون قرار میدم .

آدرس تاپیک


Impossible Impossible
Imagination is more important than science
به بلاگ من سر بزنید smile
به اینستاگرام من سر بزنید smile

آفلاین

#3 2017-04-14 13:37:18

AmiNimA
عضو
ثبت شده: 2015-11-27
ارسال ها: 221
وب سایت

پاسخ: مشکل در نصب و بروز رسانی بسته ها [حل شد]

مانجارو در آپدیت جدید اومده یه کاری کرده که سر در نیاوردم چرا؟! این فایلهایی که میبینید مربوط میشد به بسته ی nvidia-utils اگه اشتباه نکنم. وقتی آپدیت کردم، این فایلها از روی سیستم پاک شدند! و سیستم بالا نیومد. با بدبختی که دوباره اون بسته رو نصب کردم این فایلها برگشتند و سیستم بالا اومد!!
این هم احتمالا شما سیستم رو آپدیت نکردید و میخواید بسته های جدیدی رو نصب کنید که با این فایلهای قدیمی در تضاد است. میتونین یک بار آپدیت کنین کل سیستم رو بعد دوباره تلاش کنین. اما اگر بعد از آپدیت با مشکل من مواجه شدید بدونید که اشکال از کجا میتونه باشه! حالا دیگه تصمیم با خودتون

و برای آپدیت از sudo pacman -Syyu استفاده کنید نه از حالت گرافیکی

آخرین ویرایش توسط AmiNimA (2017-04-14 13:41:31)


لینوکس یک فرهنگ است. یک فرهنگ خوب

آفلاین

پانوشت انجمن

پشتیبانی توسط تیم آرچ لینوکس ایران و نیرو گرفته با FluxBB