شما هنوز به سیستم وارد نشده اید.

#1 2015-10-05 14:37:45

hamed_ubuntu
عضو
ثبت شده: 2015-09-18
ارسال ها: 13

مشکل در نصب بسته

با سلام من بسته زیر رو با شرایط زیر زدم تا نصب بشه:

[hamed@hamed ~]$ yaourt lemonpos
1 aur/lemonpos 0.9.4-rc7 (4)
    An open source Point of Sale software targeted for micro, small and medium 
    businesses.
==> Enter n° of packages to be installed (ex: 1 2 3 or 1-3)
==> -------------------------------------------------------
==> 1

بعد از دانلود صحیح بسته های زیر:

==> Downloading lemonpos PKGBUILD from AUR...
x .SRCINFO
x PKGBUILD
x lemonpos.install
lemonpos 0.9.4-rc7  (2015-07-06 14:54)
( Unsupported package: Potentially dangerous ! )
==> lemonpos dependencies:
 - kdelibs (package found)
 - automoc4 (package found)
 - cmake (package found)


==> Continue building lemonpos ? [Y/n]
==> ----------------------------------
==> 
==> Building and installing package
==> Install or build missing dependencies for lemonpos:
[sudo] password for hamed: 
resolving dependencies...
looking for conflicting packages...

Packages (13) attica-qt4-0.4.2-1  docbook-xml-4.5-6  docbook-xsl-1.78.1-1
              jsoncpp-1.6.5-1  libdbusmenu-qt4-0.9.3+15.10.20150604-1
              libutempter-1.1.6-2  media-player-info-22-1  polkit-qt4-0.112.0-1
              qca-2.0.3-5  strigi-0.7.8-7  automoc4-0.9.88-6  cmake-3.3.2-3
              kdelibs-4.14.12-1

Total Download Size:   19.40 MiB
Total Installed Size:  99.00 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages ...
 attica-qt4-0.4.2-1-...   216.4 KiB  32.4K/s 00:07 [######################] 100%
 qca-2.0.3-5-x86_64       444.0 KiB  24.6K/s 00:18 [######################] 100%
 libdbusmenu-qt4-0.9...   160.1 KiB  53.7K/s 00:03 [######################] 100%
 polkit-qt4-0.112.0-...    68.1 KiB  32.5K/s 00:02 [######################] 100%
 strigi-0.7.8-7-x86_64    582.3 KiB  20.1K/s 00:29 [######################] 100%
 docbook-xml-4.5-6-any     84.2 KiB  45.0K/s 00:02 [######################] 100%
 docbook-xsl-1.78.1-...   712.6 KiB  14.7K/s 00:49 [######################] 100%
 media-player-info-2...    36.2 KiB  56.3K/s 00:01 [######################] 100%
 libutempter-1.1.6-2...     7.3 KiB  68.6K/s 00:00 [######################] 100%
 kdelibs-4.14.12-1-x...    12.5 MiB  14.6K/s 14:35 [######################] 100%
 automoc4-0.9.88-6-x...    26.3 KiB  51.2K/s 00:01 [######################] 100%
 jsoncpp-1.6.5-1-x86_64    81.2 KiB  31.4K/s 00:03 [######################] 100%
 cmake-3.3.2-3-x86_64       4.6 MiB  17.2K/s 04:33 [######################] 100%
(13/13) checking keys in keyring                   [######################] 100%
(13/13) checking package integrity                 [######################] 100%
(13/13) loading package files                      [######################] 100%
(13/13) checking for file conflicts                [######################] 100%
( 1/13) installing attica-qt4                      [######################] 100%
( 2/13) installing qca                             [######################] 100%
( 3/13) installing libdbusmenu-qt4                 [######################] 100%
( 4/13) installing polkit-qt4                      [######################] 100%
( 5/13) installing strigi                          [######################] 100%
Optional dependencies for strigi
    kdegraphics-strigi-analyzer: strigi analyzers for various graphics file
    kdesdk-strigi-analyzers: strigi analyzers for KDE SDK
( 6/13) installing docbook-xml                     [######################] 100%
( 7/13) installing docbook-xsl                     [######################] 100%
( 8/13) installing media-player-info               [######################] 100%
( 9/13) installing libutempter                     [######################] 100%
(10/13) installing kdelibs                         [######################] 100%
(11/13) installing automoc4                        [######################] 100%
(12/13) installing jsoncpp                         [######################] 100%
(13/13) installing cmake                           [######################] 100%
Optional dependencies for cmake
    qt5-base: cmake-gui [installed]
    libxkbcommon-x11: cmake-gui [installed]

این ارور رو میده:

==> ERROR: pkgrel must be a decimal, not rc7.
==> ERROR: Missing package() function in /tmp/yaourt-tmp-hamed/aur-lemonpos/./PKGBUILD
==> ERROR: Makepkg was unable to build lemonpos.
==> Restart building lemonpos ? [y/N]
==> ---------------------------------
==> 
==> lemonpos dependencies:
 - kdelibs (already installed)
 - automoc4 (already installed)
 - cmake (already installed)


==> Continue building lemonpos ? [Y/n]
==> ----------------------------------
==> 
==> Building and installing package
==> ERROR: pkgrel must be a decimal, not rc7.
==> ERROR: Missing package() function in /tmp/yaourt-tmp-hamed/aur-lemonpos/./PKGBUILD
==> ERROR: Makepkg was unable to build lemonpos.
==> Restart building lemonpos ? [y/N]
==> ---------------------------------
==> 

لطفا راهنمایی کنید.

آفلاین

#2 2015-10-05 16:56:30

hamed_ubuntu
عضو
ثبت شده: 2015-09-18
ارسال ها: 13

پاسخ: مشکل در نصب بسته

stackoverflow نوشته است که:

داخل فایل PKGBUILD بشید و مقدار عنصر pkgrel رو از  rc7  به 7 تغییر بدید.

خب این PKGBIILD کجا هست!مسیرش منظورم هست!
و در ضمن با تغییر این مقدار آیا مشکلی پیش نمیاد؟

آفلاین

#3 2015-10-05 17:07:15

hamed_ubuntu
عضو
ثبت شده: 2015-09-18
ارسال ها: 13

پاسخ: مشکل در نصب بسته

خب دوست عزیز اون مقدار رو تغییر دادم و اون تیکه از خطا درست شد ولی بقیه خطاها جای خودشون موندن.اینم نتیجه نهایی بعد از رفع خطای rc7

==> Continue building lemonpos ? [Y/n]
==> ----------------------------------
==> 
==> Building and installing package
==> ERROR: Missing package() function in /tmp/yaourt-tmp-hamed/aur-lemonpos/./PKGBUILD
==> ERROR: Makepkg was unable to build lemonpos.
==> Restart building lemonpos ? [y/N]
==> ---------------------------------
==> 

آفلاین

#4 2015-10-05 19:08:12

Arcush
Moderator
ثبت شده: 2015-09-15
ارسال ها: 1,519

پاسخ: مشکل در نصب بسته

hamed_ubuntu نوشته است که:

خب دوست عزیز اون مقدار رو تغییر دادم و اون تیکه از خطا درست شد ولی بقیه خطاها جای خودشون موندن.اینم نتیجه نهایی بعد از رفع خطای rc7

==> Continue building lemonpos ? [Y/n]
==> ----------------------------------
==> 
==> Building and installing package
==> ERROR: Missing package() function in /tmp/yaourt-tmp-hamed/aur-lemonpos/./PKGBUILD
==> ERROR: Makepkg was unable to build lemonpos.
==> Restart building lemonpos ? [y/N]
==> ---------------------------------
==> 

در فایل PKGBUILD، بجای عبارت

 build()

عبارت

package()

رو بنویسید. فایل رو ذخیره کنید و سپس ادامه نصب.

آفلاین

#5 2015-10-08 12:54:44

hamed_ubuntu
عضو
ثبت شده: 2015-09-18
ارسال ها: 13

پاسخ: مشکل در نصب بسته

Arcush نوشته است که:
hamed_ubuntu نوشته است که:

خب دوست عزیز اون مقدار رو تغییر دادم و اون تیکه از خطا درست شد ولی بقیه خطاها جای خودشون موندن.اینم نتیجه نهایی بعد از رفع خطای rc7

==> Continue building lemonpos ? [Y/n]
==> ----------------------------------
==> 
==> Building and installing package
==> ERROR: Missing package() function in /tmp/yaourt-tmp-hamed/aur-lemonpos/./PKGBUILD
==> ERROR: Makepkg was unable to build lemonpos.
==> Restart building lemonpos ? [y/N]
==> ---------------------------------
==> 

در فایل PKGBUILD، بجای عبارت

 build()

عبارت

package()

رو بنویسید. فایل رو ذخیره کنید و سپس ادامه نصب.

خب مشکلاتی که بود حل شدن و پیش نیازها رو دانلود میکنه ولی مشکل دیگر اینه که ظاهرا نمیتونه بسته اصلی رو دانلود کنه.
البته من این مشکل رو تو نرم افزارهای دیگه هم گاها دارم.

آفلاین

#6 2015-10-08 13:21:39

Arcush
Moderator
ثبت شده: 2015-09-15
ارسال ها: 1,519

پاسخ: مشکل در نصب بسته

درسته.  سورس ۱ در https://aur.archlinux.org/packages/lemonpos/ رو ظاهرا بدون فیلترشکن نمیشه برداشت. با من با تور امتحان کردم و تونستم بسته رو دانلود کنم. فرض کنیم بسته رو دانلود کردید. در اینصورت Download snapshot در همون صفحه رو دانلود کنید و از حالت فشرده خارجش کنید. بسته ای رو هم که دانلود کردید داخل پوشه اکسترکت شده قرار بدید. فایل PKGBUILD رو با این دو تا تغییر ذخیره کنید: rc7 رو به 7 و ()build رو به ()package تغییر بدید. در ترمینال به مسیر این پوشه برید و فرمان makepkg رو صادر کنید. خروجی رو قرار بدید.

ضمنا اون Download snapshot رو میتونید با فلگ G- مربوط به packer هم دانلود کنید.

آفلاین

#7 2015-10-08 19:44:32

hamed_ubuntu
عضو
ثبت شده: 2015-09-18
ارسال ها: 13

پاسخ: مشکل در نصب بسته

سلام نرم افزار رو بلاخره کامپایل کردم و نصب شد
الان مشکل من دیتابیس هست.
بر نامه رو باز میکنم میگه پایگاه داده یافت نشد!
من برنامه mysql رو نصب کردم.
و الان این کد رو که میزنم خطای زیر رو میده:

 sudo systemctl start mysqld && mysql_secure_installation

NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MariaDB
      SERVERS IN PRODUCTION USE!  PLEASE READ EACH STEP CAREFULLY!

In order to log into MariaDB to secure it, we'll need the current
password for the root user.  If you've just installed MariaDB, and
you haven't set the root password yet, the password will be blank,
so you should just press enter here.

Enter current password for root (enter for none): 
//usr/bin/mysql: error while loading shared libraries: libncursesw.so.6: cannot open shared object file: No such file or directory
OK, successfully used password, moving on...

Setting the root password ensures that nobody can log into the MariaDB
root user without the proper authorisation.

Set root password? [Y/n] y
New password: 
Re-enter new password: 
//usr/bin/mysql: error while loading shared libraries: libncursesw.so.6: cannot open shared object file: No such file or directory
Password update failed!
Cleaning up...
 

آفلاین

#8 2015-10-08 20:16:34

Arcush
Moderator
ثبت شده: 2015-09-15
ارسال ها: 1,519

پاسخ: مشکل در نصب بسته

با این دستور کل سیستم رو آپدیت کنید:

 $ sudo pacman -Syyu

آرچ یک توزیع غلطانه و بهترین عملکردش در موقعی هست که کاملا آپدیت باشه. اولین راه حل خطاهایی ازین قبیل، استفاده از دستور بالا هست.

آخرین ویرایش توسط Arcush (2015-10-08 20:16:47)

آفلاین

پانوشت انجمن

پشتیبانی توسط تیم آرچ لینوکس ایران و نیرو گرفته با FluxBB