شما هنوز به سیستم وارد نشده اید.

#1 2018-07-01 11:32:48

negarsoft
عضو
ثبت شده: 2017-04-04
ارسال ها: 14

پیدا کردن بسته های وابسته به بک بسته در مخازن( حل شد)

سلام
من می خوام ببینم که چه بسته های به یک بسته نیاززدارند؟ منتها این بسته هنوز نصب نشده .

مشکل اصلی این هست که الان من می خوام آپدیت کنم و پکمن خطا می ده که :
:: systemd and eudev are in conflict
ولی من فقط systemd دارم پس حتما موقع آپدیت کردن یکی از نرم افزارهام eudev رو به عنوان یک پیشنیاز می خواد نصب کنه که به خطا می خوره. حالا می خوام پیدا کنم که اون کدوم نرم افزاره که در نسخه جدیدش نیاز به eudev داره.
من این آرچ رو از kde3 دارم و چند سال پیش هم به پارابولا مهاجرت کردم  و سالی دو بارهم بیشتر آپدیت نمی کنم. به همین خاطرکلی بسته های زیادی و منقرض شده داره  که وضع سیستم رو بهم می ریزند. و فکر می کنم یک نرم افزار قدیمی این مشکل رو ایجاد کرده.

آخرین ویرایش توسط negarsoft (2018-07-02 19:19:30)


سید وحیدرضا برهانی!
نگارسافت یک اسم نوستالژیکه از زمان های خیلی قدیم . پسر هستم!

آفلاین

#2 2018-07-01 22:07:22

حسین حیدری
Moderator
از : اصفهان
ثبت شده: 2015-09-16
ارسال ها: 412

پاسخ: پیدا کردن بسته های وابسته به بک بسته در مخازن( حل شد)

negarsoft نوشته است که:

سلام
من می خوام ببینم که چه بسته های به یک بسته نیاززدارند؟ منتها این بسته هنوز نصب نشده .

مشکل اصلی این هست که الان من می خوام آپدیت کنم و پکمن خطا می ده که :
:: systemd and eudev are in conflict
ولی من فقط systemd دارم پس حتما موقع آپدیت کردن یکی از نرم افزارهام eudev رو به عنوان یک پیشنیاز می خواد نصب کنه که به خطا می خوره. حالا می خوام پیدا کنم که اون کدوم نرم افزاره که در نسخه جدیدش نیاز به eudev داره.
من این آرچ رو از kde3 دارم و چند سال پیش هم به پارابولا مهاجرت کردم  و سالی دو بارهم بیشتر آپدیت نمی کنم. به همین خاطرکلی بسته های زیادی و منقرض شده داره  که وضع سیستم رو بهم می ریزند. و فکر می کنم یک نرم افزار قدیمی این مشکل رو ایجاد کرده.


درود؛

میتونید از دو فرمان زیر استفاده کنید:

pacman -Si folan_PKG # if it is not installed
pacman -Qi folan_PKG # if it is installed

Just an anime fan

آفلاین

#3 2018-07-01 22:48:39

Arcush
Moderator
ثبت شده: 2015-09-15
ارسال ها: 1,459

پاسخ: پیدا کردن بسته های وابسته به بک بسته در مخازن( حل شد)

درودهای بسیار. درکنار آنچه که حسین گرامی برنوشت، میتونیم برای نمونه از

$ pacman -Sii MY_PKG | grep Required # pacman -S -h | grep ii

و یا دستور مدرن ترِ

$ expac -S %N MY_PKG # man expac | grep required

هم سود ببریم.

negarsoft@ گرامی، از eudev که در   AUR (در yaourt (: ) است به چه دلیل دارید استفاده می کنید؟ صفحه ش را در AUR بنگرید که توسط eudev-systemd بکار گرفته میشه. حذفش کنید و سیستم را آپگرید.

پ.ن: جناب برهانیِ گرامی، در انجمن اوبونتو ارسال های شما را همواره میخوندم و آرزوی این را داشتم که از اطلاعات مفیدتون بهره ببرم. الان، با توجه به امضاتون متوجه شدم که در این انجمن هم عضو هستید. به یقین باعث خوشوختیِ دوستانتون در انجمن خواهد بود اگر بیشتر فعالیت کنید و در نتیجه یک انجمن گسترده تر و مفیدتر داشته باشیم. با امتنان.

آخرین ویرایش توسط Arcush (2018-07-02 00:49:01)

آفلاین

#4 2018-07-02 20:00:05

negarsoft
عضو
ثبت شده: 2017-04-04
ارسال ها: 14

پاسخ: پیدا کردن بسته های وابسته به بک بسته در مخازن( حل شد)

ممنون
pacman -Si کار نمی کنه ولی Sii و expac کار می کنند
راستش من از eudev استفاده نمی کردم فقط موقع آپدیت می خواست (eudev توی پارابولا توی مخازن pcr هم وجود داره) راستش دقیقا نمی دونم چرا همچین چیزی رو می خواست نصب کنه من یکسری چیزهایی رو آپدیت  کردم مثل systemd-sysvcompat (نسخه مخصوص پارابولا از مخزن libre ) که بعدش اون تداخل دیگه پیش نیومد. می گم مدریت بسته هام از دستم در رفته.

باعث خوشحالی  هست که بتونم کاری انجام بدم. توانایی من بیشتر توی شل اسکریپت هست.  smile


سید وحیدرضا برهانی!
نگارسافت یک اسم نوستالژیکه از زمان های خیلی قدیم . پسر هستم!

آفلاین

#5 2018-07-04 12:05:32

حسین حیدری
Moderator
از : اصفهان
ثبت شده: 2015-09-16
ارسال ها: 412

پاسخ: پیدا کردن بسته های وابسته به بک بسته در مخازن( حل شد)

negarsoft نوشته است که:

ممنون
pacman -Si کار نمی کنه ولی Sii و expac کار می کنند
راستش من از eudev استفاده نمی کردم فقط موقع آپدیت می خواست (eudev توی پارابولا توی مخازن pcr هم وجود داره) راستش دقیقا نمی دونم چرا همچین چیزی رو می خواست نصب کنه من یکسری چیزهایی رو آپدیت  کردم مثل systemd-sysvcompat (نسخه مخصوص پارابولا از مخزن libre ) که بعدش اون تداخل دیگه پیش نیومد. می گم مدریت بسته هام از دستم در رفته.

باعث خوشحالی  هست که بتونم کاری انجام بدم. توانایی من بیشتر توی شل اسکریپت هست.  smile

کار نمیکنه؟! عجیبه!

مثالش:

(1)[hossein][~]--> $ pacman -Si firefox
Repository      : extra
Name            : firefox
Version         : 61.0-1
Description     : Standalone web browser from mozilla.org
Architecture    : x86_64
URL             : https://www.mozilla.org/firefox/
Licenses        : MPL  GPL  LGPL
Groups          : None
Provides        : None
Depends On      : gtk3  mozilla-common  libxt  startup-notification  mime-types  dbus-glib  ffmpeg  nss  hunspell-en_US  sqlite  ttf-font  libpulse  libvpx  icu
Optional Deps   : networkmanager: Location detection via available WiFi networks
                  libnotify: Notification integration
                  pulseaudio: Audio support
                  speech-dispatcher: Text-to-Speech
Conflicts With  : None
Replaces        : None
Download Size   : 36.47 MiB
Installed Size  : 136.72 MiB
Packager        : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Build Date      : Tue 26 Jun 2018 11:16:41 PM +0430
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Just an anime fan

آفلاین

#6 2018-07-09 23:24:06

negarsoft
عضو
ثبت شده: 2017-04-04
ارسال ها: 14

پاسخ: پیدا کردن بسته های وابسته به بک بسته در مخازن( حل شد)

آره کار نمی کنه ( یعنی اون چیزی که می خوام نیست . نه اینکه خروجی نداشته باشه)
اگر دقت کنی si فقط دپنسی رو می گه ولی sii می گه که چه بسته هایی این بسته موردنظر رو نیاز دارند.
si خروجی قسمت  Required By  رو نداره.


سید وحیدرضا برهانی!
نگارسافت یک اسم نوستالژیکه از زمان های خیلی قدیم . پسر هستم!

آفلاین

پانوشت انجمن

پشتیبانی توسط تیم آرچ لینوکس ایران و نیرو گرفته با FluxBB