شما هنوز به سیستم وارد نشده اید.

#1 2018-10-02 20:32:12

Arcush
Moderator
ثبت شده: 2015-09-15
ارسال ها: 1,441

رفع مشکل خطای برخی کتابخانه ها در Mathematica

بسیاری از نرم افزارها وختی توسط کاربر در opt یا usr/local/ نصب میشن از کتابخانه های از پیش ساخته شدهٔ خودشون به صورت پیشفرض استفاده می کنند و  در غیر اینصورت در سیستم عامل میگردند تا اون کتابخونه ها را یافته و ازشون استفاده کنند. بنابراین نخستین ایده برای رفع خطاهایی که برخواسته از نقصی در اثر استفاده از کتابخونه های خود نرم افزار این هست که نرم افزار را مجبور کنیم از کتابخونه های سیستمی استفاده کنه. این مشکل امروز در نصب Mathematica برای من رخ داد.
برای رفع خطای در اجرای Mathematica:

/usr/local/Wolfram/Mathematica/11.0/SystemFiles/FrontEnd/Binaries/Linux-x86-64/Mathematica: /usr/local/Wolfram/Mathematician/11.0/SystemFiles/Libraries/Linux-x86-64/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib/libpng16.so.16)

به طریق زیر اقدام کنید:

$ sudo mv ./libfreetype.so.6 ./libfreetype.so.6.old
$ sudo mv ./libz.so.1 ./libz.so.1.old

که /. عبارت است از

/usr/local/Wolfram/Mathematica/11.0/SystemFiles/Libraries/Linux-x86-64/

آفلاین

پانوشت انجمن

پشتیبانی توسط تیم آرچ لینوکس ایران و نیرو گرفته با FluxBB