شما هنوز به سیستم وارد نشده اید.

اطلاعیه

#1 2021-02-12 02:03:16

mr-noip
عضو
ثبت شده: 2018-07-13
ارسال ها: 51

اضافه کردن پارامتر کرنل هنگام بوت(به روش غیر استاندارد حل شد)

سلام و عرض ادب.دوستان بنده یک مشکلی در استفاده از دو مانیتور با لپ تاپ داشتم و این مشکل با تغییراتی در فایل کانفیک X11 رفع شد.
اما باید هر دفعه به صورت دستی ماژول زیر رو لود کنم :

nvidia-drm modeset=on

در فایل mkinitcpio ماژول لود شده اما پارامتر دوم رو نمیگیره.در گراب هم قرار دادم اما فایدهای نداشت.برای استفاده از دو مانیتور هم بعد از لود ماژول با پارامتری که نوشتم باید یک بار از میز کار گنوم لاگ اوت کنم.

به چه صورتی میتونم در موقع بوت این پارامتر رو اضافه کنم؟

آخرین ویرایش توسط mr-noip (2021-02-12 17:37:43)


شروعی جدید smile

آفلاین

#2 2021-02-12 17:37:09

mr-noip
عضو
ثبت شده: 2018-07-13
ارسال ها: 51

پاسخ: اضافه کردن پارامتر کرنل هنگام بوت(به روش غیر استاندارد حل شد)

بعد از بررسی متوجه شدم ماژول nvidia-drm اصلا لود نمیشه.

راه حلی جز این به ذهنم نرسید که مینویسم تا شاید به درد کسی بخوره :
در یک اسکریپت bash کامندی که برای لود ماژول هست رو قرار دادم

#! /bin/bash
modprobe nvidia-drm modeset=on

و یک سرویس در systemd تعریف کردم تا هر زمان سیستم لود شد به صورت خودکار این کامند اجرا بشه.

systemd/system/drm-manul.service

[Unit]
Description=drm-manual

[Service]
ExecStart=/bin/bash  path/to/file

[Install]
WantedBy=multi-user.target

بدیهی است که به جای path/to/file باید آدرس اسکریپت رو بهش بدید.

و بعد هم سرویسی که تعریف کردم رو فعال کردم تا موقع بوت به صورت خودکار لود بشه :

systemctl enable --now drm-manual.service

شروعی جدید smile

آفلاین

#3 2021-02-14 10:14:42

morealaz
Moderator
ثبت شده: 2016-03-19
ارسال ها: 374

پاسخ: اضافه کردن پارامتر کرنل هنگام بوت(به روش غیر استاندارد حل شد)

mr-noip نوشته است که:

سلام و عرض ادب.دوستان بنده یک مشکلی در استفاده از دو مانیتور با لپ تاپ داشتم و این مشکل با تغییراتی در فایل کانفیک X11 رفع شد.
اما باید هر دفعه به صورت دستی ماژول زیر رو لود کنم :

nvidia-drm modeset=on

در فایل mkinitcpio ماژول لود شده اما پارامتر دوم رو نمیگیره.در گراب هم قرار دادم اما فایدهای نداشت.برای استفاده از دو مانیتور هم بعد از لود ماژول با پارامتری که نوشتم باید یک بار از میز کار گنوم لاگ اوت کنم.

به چه صورتی میتونم در موقع بوت این پارامتر رو اضافه کنم؟

چند تا کار میتونید انجام بدید:
اولیش اینه که در دایرکتوری  /etc/modprobe.d/ یه فایل کانفیگ مثلا به اسم nvidia.conf بسازید و محتویاتش رو به این صورت قرار بدید:

options nvidia-drm modeset=on

البته این برای زمانی هست که پارامتر modeset=on مربوط به ماژول nvidia-drm باشد.
حالت بعدی این هست که ماژول رو میخواهد در ابتدای شروع سیستم و زمانی که ramdisk اولیه سیستم لود می شود بارگذاری کنید که در این حالت باید نام ماژول nvidia-drm را به متغیر MODULES در فایل etc/mkinitcpio.conf/ اضافه کنید و با دستور mkinitcpio مجدد initrm را بازسازی کنید و پارامتر modeset=on را از طریق فایل تنظیمات bootloader خود به عنوان پارامتر خط فرمان کرنل در هنگام بوت تنظیم کنید.
طبق توضیحات
https://wiki.archlinux.org/index.php/NV … de_setting
در مورد ماژول nvidia-drm شما میتوانید این ماژول را با اضافه کردن nvidia-drm.modeset=1 به پارامترهای کرنل در موقع بوت از طریق boot loder خود فعال کنید و اگر میخواهید این ماژول در ابتدای بوت سیستم و به هنگام بارگذاری ramdisk اولیه بارگذاری شود باید ماژولهای nvidia و nvidia_modeset و nvidia_uvm و nvidia_drm را به فایل mkinitcpio.conf که قبلا توضیح داده شد اضافه کنید.

آفلاین

#4 2021-02-15 01:20:14

mr-noip
عضو
ثبت شده: 2018-07-13
ارسال ها: 51

پاسخ: اضافه کردن پارامتر کرنل هنگام بوت(به روش غیر استاندارد حل شد)

morealaz نوشته است که:
mr-noip نوشته است که:

سلام و عرض ادب.دوستان بنده یک مشکلی در استفاده از دو مانیتور با لپ تاپ داشتم و این مشکل با تغییراتی در فایل کانفیک X11 رفع شد.
اما باید هر دفعه به صورت دستی ماژول زیر رو لود کنم :

nvidia-drm modeset=on

در فایل mkinitcpio ماژول لود شده اما پارامتر دوم رو نمیگیره.در گراب هم قرار دادم اما فایدهای نداشت.برای استفاده از دو مانیتور هم بعد از لود ماژول با پارامتری که نوشتم باید یک بار از میز کار گنوم لاگ اوت کنم.

به چه صورتی میتونم در موقع بوت این پارامتر رو اضافه کنم؟

چند تا کار میتونید انجام بدید:
اولیش اینه که در دایرکتوری  /etc/modprobe.d/ یه فایل کانفیگ مثلا به اسم nvidia.conf بسازید و محتویاتش رو به این صورت قرار بدید:

options nvidia-drm modeset=on

البته این برای زمانی هست که پارامتر modeset=on مربوط به ماژول nvidia-drm باشد.
حالت بعدی این هست که ماژول رو میخواهد در ابتدای شروع سیستم و زمانی که ramdisk اولیه سیستم لود می شود بارگذاری کنید که در این حالت باید نام ماژول nvidia-drm را به متغیر MODULES در فایل etc/mkinitcpio.conf/ اضافه کنید و با دستور mkinitcpio مجدد initrm را بازسازی کنید و پارامتر modeset=on را از طریق فایل تنظیمات bootloader خود به عنوان پارامتر خط فرمان کرنل در هنگام بوت تنظیم کنید.
طبق توضیحات
https://wiki.archlinux.org/index.php/NV … de_setting
در مورد ماژول nvidia-drm شما میتوانید این ماژول را با اضافه کردن nvidia-drm.modeset=1 به پارامترهای کرنل در موقع بوت از طریق boot loder خود فعال کنید و اگر میخواهید این ماژول در ابتدای بوت سیستم و به هنگام بارگذاری ramdisk اولیه بارگذاری شود باید ماژولهای nvidia و nvidia_modeset و nvidia_uvm و nvidia_drm را به فایل mkinitcpio.conf که قبلا توضیح داده شد اضافه کنید.


سلام و عرض ادب.

همهی این کارها رو انجام داده بودم متاسفانه لود نمیشه به این صورت.

MODULES=(i915 nvidia nvidia-uvm nvidia-modeset drm drm_kms_helper drm_vram_helper vboxvideo ttm nvidia-drm )

در فایل /etc/default/grub این کارها رو اضافه کردم :

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet acpi_osi= pcie_aspm=force i915.i915_enable_rc6=1 nvidia-drm.modeset=1"

در /etc/modprobe.d/ هم یک فایل ایجاد شده با نام nvidia-drm با محتوای زیر :

options nvidia-drm modeset=on

اما متاسفانه بعد بوت شدن لود نمیشه!


شروعی جدید smile

آفلاین

#5 2021-02-15 08:10:13

morealaz
Moderator
ثبت شده: 2016-03-19
ارسال ها: 374

پاسخ: اضافه کردن پارامتر کرنل هنگام بوت(به روش غیر استاندارد حل شد)

mr-noip نوشته است که:

سلام و عرض ادب.

همهی این کارها رو انجام داده بودم متاسفانه لود نمیشه به این صورت.

MODULES=(i915 nvidia nvidia-uvm nvidia-modeset drm drm_kms_helper drm_vram_helper vboxvideo ttm nvidia-drm )

در فایل /etc/default/grub این کارها رو اضافه کردم :

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet acpi_osi= pcie_aspm=force i915.i915_enable_rc6=1 nvidia-drm.modeset=1"

در /etc/modprobe.d/ هم یک فایل ایجاد شده با نام nvidia-drm با محتوای زیر :

options nvidia-drm modeset=on

اما متاسفانه بعد بوت شدن لود نمیشه!

چیزی که من می بینم شما هم ماژولهای اینتل رو بارگذاری کردید و هم ماژولهای انویدیا. اینجوری فکر میکنم که اینتل رشته کار رو در دست میگیره و انویدیا لود نمیشه. به نظرم فقط ماژولهای انویدیا رو باید لود کنید. شما کلی ماژول دیگه هم لود کردید!!!

آفلاین

#6 2021-02-16 16:43:03

mr-noip
عضو
ثبت شده: 2018-07-13
ارسال ها: 51

پاسخ: اضافه کردن پارامتر کرنل هنگام بوت(به روش غیر استاندارد حل شد)

morealaz نوشته است که:
mr-noip نوشته است که:

سلام و عرض ادب.

همهی این کارها رو انجام داده بودم متاسفانه لود نمیشه به این صورت.

MODULES=(i915 nvidia nvidia-uvm nvidia-modeset drm drm_kms_helper drm_vram_helper vboxvideo ttm nvidia-drm )

در فایل /etc/default/grub این کارها رو اضافه کردم :

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet acpi_osi= pcie_aspm=force i915.i915_enable_rc6=1 nvidia-drm.modeset=1"

در /etc/modprobe.d/ هم یک فایل ایجاد شده با نام nvidia-drm با محتوای زیر :

options nvidia-drm modeset=on

اما متاسفانه بعد بوت شدن لود نمیشه!

چیزی که من می بینم شما هم ماژولهای اینتل رو بارگذاری کردید و هم ماژولهای انویدیا. اینجوری فکر میکنم که اینتل رشته کار رو در دست میگیره و انویدیا لود نمیشه. به نظرم فقط ماژولهای انویدیا رو باید لود کنید. شما کلی ماژول دیگه هم لود کردید!!!

ممنون از وقتی که قرار میدید.دقیقا طبق چیزایی که فرمودید پیش رفتم این بار.
اما مجددا مشکل پابرجاست.


شروعی جدید smile

آفلاین

پانوشت انجمن

پشتیبانی توسط تیم آرچ لینوکس ایران و نیرو گرفته با FluxBB