شما هنوز به سیستم وارد نشده اید.

اطلاعیه

#1 2021-05-13 14:43:23

vahedi
عضو
ثبت شده: 2021-05-13
ارسال ها: 3

مشکل در لود نشدن ramdisk

سلام وقت بخیر
دوستان آرچ رو بر روی ویرچوال باکس و وی ام ویر نصب کردم
اما پس از نصب که ریبوت دادم گراب لود میشه و در نهایت مانند تصویر زیر گیر میکند
photo-2021-05-12-22-00-30.jpg
لطفا راهنمایی بفرمایید مشکل از کجاست
باتشکر

آفلاین

#2 2021-05-13 15:09:38

alireza138812
عضو
ثبت شده: 2021-02-09
ارسال ها: 21

پاسخ: مشکل در لود نشدن ramdisk

سلام.
از روی iso ارچ chroot کنید.
و بعد این دستور را بزنید.
mkinitcpio -p linux

آفلاین

#3 2021-05-13 16:33:45

vahedi
عضو
ثبت شده: 2021-05-13
ارسال ها: 3

پاسخ: مشکل در لود نشدن ramdisk

سلام
متوجه نشدم درست
iso ارچ رو به صورت لایو بیارم بالا؟
بعد توی ترمینال بزنم chroot و mkinitcpio -p linux ؟!

آفلاین

#4 2021-05-13 17:24:18

alireza138812
عضو
ثبت شده: 2021-02-09
ارسال ها: 21

پاسخ: مشکل در لود نشدن ramdisk

ببینید شما اول باید ارچ لینوکس را لایو بوت کنید و بعد پارتیشن هایی که موقع نصب ارچ ساختید را mount کنید.
برای این کار بزنید :
mount /dev/sdaN /mnt
به جای sdaN اسم پارتیشن روت را بزنید.
و بعد :
mount --rbind /dev  /mnt/dev
mount --rbind /proc /mnt/proc
mount --rbind /sys  /mnt/sys
حالا با ابن درستور chroot کنید.
chroot /mnt /usr/bin/bash
حالا بزنید :
mkinitcpio -p linux
و حالا وقتی کار دستور بالا تمام شد بزنید :
exit
reboot
امیدوارم مشکلتان حل بشه.

آفلاین

#5 2021-05-13 19:28:27

vahedi
عضو
ثبت شده: 2021-05-13
ارسال ها: 3

پاسخ: مشکل در لود نشدن ramdisk

دستوراتی که گفتین نتیجه اش :
mount /dev/sda3 /mnt
[ arch ~ ]# mount --rbind /proc /mnt/proc
[ arch ~ ]# mount --rbind /sys /mnt/sys
[ arch ~ ]# chroot /mnt /usr/bin/bash
tput: unknown terminal "xterm-256color"
tput: unknown terminal "xterm-256color"
tput: unknown terminal "xterm-256color"
tput: unknown terminal "xterm-256color"
tput: unknown terminal "xterm-256color"
tput: unknown terminal "xterm-256color"
tput: unknown terminal "xterm-256color"
tput: unknown terminal "xterm-256color"
tput: unknown terminal "xterm-256color"
[ arch / ]# mkinitcpio -p linux
==> WARNING: Failed to enable color. Check your TERM environment variable
==> ERROR: /dev must be mounted!

و در آخر هم exit و ریبوت زدم ولی باز هم همون مرحله گیر میکنه !
پارتیشن بندیم به این صورت بوده
sda1 = 1G Boot
sda2 = 4G swap
sda3 = 45G /
بوده

آخرین ویرایش توسط vahedi (2021-05-13 19:28:46)

آفلاین

#6 2021-05-13 21:20:33

alireza138812
عضو
ثبت شده: 2021-02-09
ارسال ها: 21

پاسخ: مشکل در لود نشدن ramdisk

alireza138812 نوشته است که:

ببینید شما اول باید ارچ لینوکس را لایو بوت کنید و بعد پارتیشن هایی که موقع نصب ارچ ساختید را mount کنید.
برای این کار بزنید :
mount /dev/sdaN /mnt
به جای sdaN اسم پارتیشن روت را بزنید.
و بعد :
mount --rbind /dev  /mnt/dev
mount --rbind /proc /mnt/proc
mount --rbind /sys  /mnt/sys
حالا با ابن درستور chroot کنید.
chroot /mnt /usr/bin/bash
حالا بزنید :
mkinitcpio -p linux
و حالا وقتی کار دستور بالا تمام شد بزنید :
exit
reboot
امیدوارم مشکلتان حل بشه.

قبل از این دستورات توی لایو بزنید: export TERM=xterm

آفلاین

#7 2022-01-24 16:30:40

amircb
عضو
ثبت شده: 2020-09-11
ارسال ها: 4

پاسخ: مشکل در لود نشدن ramdisk

alireza138812 نوشته است که:

سلام.
از روی iso ارچ chroot کنید.
و بعد این دستور را بزنید.
mkinitcpio -p linux

منم همین مشکل را داشتم . این کار را انجام دادم خروجیش اینه(البته فقط warningهاش نوشتم):

ٌٌWARNING: Possibly missing firmware for module:xhci_pci
WARNING: Possibly missing firmware for module:qla2xxx
WARNING: Possibly missing firmware for module:bfa
WARNING: Possibly missing firmware for module:qed
WARNING: Possibly missing firmware for module:qla1280
WARNING: Possibly missing firmware for module:aic94xx
WARNING: Possibly missing firmware for module:wd719x

آفلاین

#8 2022-01-25 11:43:43

amircb
عضو
ثبت شده: 2020-09-11
ارسال ها: 4

پاسخ: مشکل در لود نشدن ramdisk

تمامش از aur نصب کردم بعدش دستور mkinitcpio -p linux را اجرا کردم و بدون اخطارها اجرا تمام بسته ها را ساخت بعدش دوباره گراب ساختم اونم بدون ارور اجرا شد ولی بازم لود نشد

آخرین ویرایش توسط amircb (2022-01-25 13:22:54)

آفلاین

پانوشت انجمن

پشتیبانی توسط تیم آرچ لینوکس ایران و نیرو گرفته با FluxBB میزبانی توسط MahanCloud